Errors accessing Online Forms RAC
Incident Report for DonorPerfect
Resolved
The reported issues have been resolved. The online forms RAC is now viewable as well as pending transactions. Thank you for your patience while we worked to fix issue.
Posted Jul 29, 2021 - 16:24 EDT
Investigating
We are receiving reports of issues accessing and viewing pending Online Form transactions via the RAC. Online forms are still accessible and processing transactions successfully. We are investigating this issue.
Posted Jul 29, 2021 - 16:04 EDT
This incident affected: DonorPerfect Online Forms.