Payment Issues with ACH (e-Check) Processing
Incident Report for DonorPerfect
Resolved
ACH processing issues started at 4:13 AM EDT and continued until 10:05 AM EDT. Our provider has not seen any further problematic transactions since.
Posted Aug 15, 2016 - 13:11 EDT
Monitoring
Our partner has resolved the ACH/e-Check payment issues and service has resumed. We will continue to monitor the situation to ensure service is stable.
Posted Aug 15, 2016 - 10:20 EDT
Identified
Our payment processing partner is experiencing issues processing ACH/e-Check payments. This potentially impacts bank account payments processed through Insta-Charge, EFT and WebLink. Credit card processing is not impacted. Our partner is working diligently to resolve this issue.
Posted Aug 15, 2016 - 08:57 EDT