Phones and Internet down for DonorPerfect Canada
Incident Report for DonorPerfect
Resolved
We have confirmed with the vendor that the phones and internet at our Canadian office are now fully operational. Thank you for your patience while we worked with our partner to resolve the issue.
Posted Sep 09, 2015 - 12:05 EDT
Update
We're still working with the vendor to resolve the issue. Please continue to contact U.S. support for any assistance. We'll update you when the issue has been resolved.
Posted Sep 08, 2015 - 16:20 EDT
Investigating
The DonorPerfect Canada team is currently experiencing technical difficulties with their phones and internet. Please call [(215) 628-4343], email (support@donorperfect.com), or chat (accessible through the Help Menu in DonorPerfect) our U.S. support team if you need any assistance. We're monitoring the situation and will update you when the issue has been resolved.
Posted Sep 08, 2015 - 10:06 EDT