Credit Card Processing Issue for a Subset of Clients
Incident Report for DonorPerfect
Resolved
Our processing partner has confirmed that the issue has been resolved. Thank you for your patience as this issue was resolved.
Posted Jan 03, 2019 - 16:32 EST
Monitoring
Our payment processing partner has notified us that they are no longer seeing processing errors. They are currently monitoring the issue and will communicate regarding a final resolution. Thank you for your patience, and we will continue to keep you updated here.
Posted Jan 03, 2019 - 15:57 EST
Update
Our payment processing vendor has notified us that ACH (e-check) payments are also failing in addition to credit card payments. We apologize for any difficulty this is causing you, and we'll post another update when we receive more information from our vendor.
Posted Jan 03, 2019 - 12:43 EST
Update
We have been notified by our payment processing partner that there is an issue processing credit card payments upstream of us. This issue is affecting a subset of clients, not every client. We currently know that it is affecting only credit card processing. We apologize for this inconvenience, and we will keep you updated as we learn more from our vendor.
Posted Jan 03, 2019 - 12:35 EST
Investigating
We have been notified by our payment processing partner that there is an issue processing credit card payments upstream of us. This issue is affecting a subset of clients, not every client. We currently know that it is affecting only credit card processing. We apologize for this inconvenience, and we will keep you updated as we learn more from our vendor.
Posted Jan 03, 2019 - 12:22 EST
This incident affected: DonorPerfect Online Forms, SafeSave Payments Gateway, and ReadySetAuction.