Mastercard Payment Issue
Incident Report for DonorPerfect
Resolved
Mastercard has confirmed that the issue has been resolved. Some Mastercard transactions may have been denied early this morning. Thank you for your patience as we waited for a resolution to this issue.
Posted May 10, 2018 - 10:34 EDT
Investigating
We have received a report that the Mastercard network is having issues, and we have seen several Mastercard transactions fail. We will post any updates we receive here on the StatusPage.
Posted May 10, 2018 - 09:41 EDT
This incident affected: SafeSave Payments Gateway.