DonorPerfect Login Issue
Incident Report for DonorPerfect
Postmortem

At approximately 1:54PM today, our monitoring service alerted us to an inability to log into DonorPerfect via our API. We shortly thereafter confirmed that clients were also unable to log in, though clients who were already logged in were able to continue to work in many instances.

Our support team analyzed the situation and realized that a critical table used by our login process was missing data. Because this data is regularly replicated and backed-up multiple times per day, the team was able to restore the missing data quickly and login service was restored at 2:12pm. We confirmed shortly after that all services were back and continued to monitor the situation. No other residual issues were noted.

What Happened: In researching a root cause, our team found that a data replication process was inadvertently configured to run against itself on one of our servers, effectively deleting data held within that table and causing login attempts to fail.

What are we doing: The process has been re-coded and re-deployed to prevent this from happening in the future.

Posted May 18, 2016 - 17:49 EDT

Resolved
All DPO functionality and services have been fully restored.
Posted May 18, 2016 - 17:47 EDT
Monitoring
Login access has been restored. We are confirming that no other issues remain. We'll keep you updated here.
Posted May 18, 2016 - 14:20 EDT
Investigating
Various clients are reporting that that they are unable to login to their DonorPerfect system. Some are receiving an "Incorrect Password" message while others are receiving various other error messages. WebLink users will still be able to login, but may see errors or alerts when logging into the RAC, accessing fields, code lists, Gateway information, etc. We're investigating the issue and will update you here when we learn the cause and/or resolve the issue.
Posted May 18, 2016 - 14:02 EDT