Intermittent DonorPerfect Online Forms Issue
Incident Report for DonorPerfect
Postmortem

Approximately 19:00 EST we detected a flood of fraudulent attempts to process illegitimate card transactions. This attempt was recognized and prevented by our gateway security, but the attempt slowed responses on some forms, or caused other forms not to load at all. We responded and restored service to all forms by 19:29 EST and we will continue monitoring for any additional attempts. We appreciate your support as we continuously look for better ways to improve our forms and detect and prevent these fraudulent processing attempts.

Posted Jan 15, 2020 - 20:22 EST

Resolved
We have resolved the Online Forms issue. Thank you for your patience as we resolved this issue, and we will post more details about the issue in a post mortem update as we collect more information.
Posted Jan 15, 2020 - 19:43 EST
Investigating
We are currently investigating an intermittent issue with DonorPerfect Online Forms that is causing an error when someone accesses a form. We apologize for this inconvenience, and we are working hard to resolve this issue as quickly as possible.
Posted Jan 15, 2020 - 19:07 EST
This incident affected: DonorPerfect Online Forms.