Issues Logging Into the SafeSave Payments Gateway
Incident Report for DonorPerfect
Resolved
As of 1:04 PM ET, traffic routes have normalized. The issue appears to be related to an isolated carrier in the southern midwest of the US, affecting some clients within that region. We will continue to monitor the situation.
Posted Oct 13, 2016 - 13:46 EDT
Investigating
Some clients are reporting timeout issues when attempting to log in to the Gateway. The problem appears to be isolated to certain internet providers. We will keep you updated here.
Posted Oct 13, 2016 - 13:24 EDT