DonorPerfect Slowness
Incident Report for DonorPerfect
Resolved
We identified the process that was causing slowness in DonorPerfect and have implemented a fix to resolve the issue. Thank you for your patience.
Posted Sep 11, 2020 - 10:25 EDT
Investigating
We're currently investigating reports of slowness in DonorPerfect during login and when accessing a donor record or the Report Center. We apologize for this inconvenience and are working hard to resolve the issue.
Posted Sep 11, 2020 - 09:46 EDT
This incident affected: DonorPerfect.