Intermittent Dashboard Issues
Incident Report for DonorPerfect
Resolved
We've confirmed that the Dashboard issue is resolved. Thank you for your patience as we improve your DonorPerfect experience.
Posted Jul 02, 2018 - 12:14 EDT
Monitoring
We've implemented a solution, and we believe the issues have been fixed. We'll continue to monitor the results to ensure all issues have been resolved. Thank you for your patience.
Posted Jul 02, 2018 - 11:18 EDT
Investigating
We are currently investigating an issue with Dashboards not loading properly. We apologize for any inconvenience and are working hard to resolve this issue.
Posted Jul 02, 2018 - 11:03 EDT
This incident affected: DonorPerfect.