Some Clients Unable to Process Payments
Incident Report for DonorPerfect
Resolved
We have received notice from our provider that service has been restored.

The entire scope of impact is very difficult to ascertain. The issues were often isolated to certain regions and intermittent. In all, the DNS vendor is reporting that the bulk of the issues occurred 7:10 AM thru 1:45 PM ET. Thank you for your patience in this unique situation.
Posted Oct 21, 2016 - 19:54 EDT
Investigating
It appears that the DNS issues we reported this morning have resumed. Our vendor is working to resolve the issue as quickly as possible. The issues are sporadic and we are still trying to understand what regions are most affected (though it seems to be predominately U.S. East Coast). We'll keep you posted here.
Posted Oct 21, 2016 - 15:40 EDT