DonorPerfect Login Issues
Incident Report for DonorPerfect
Resolved
The login issue has been resolved. Thank you for your patience as our team resolved the issue.
Posted Mar 06, 2018 - 17:59 EST
Monitoring
We've implemented a solution and there are currently no issues logging into DonorPerfect. We'll continue to monitor the issue to confirm it has been completely resolved. We apologize for any inconvenience this might have caused you and appreciate your patience.
Posted Mar 06, 2018 - 16:43 EST
Investigating
We are currently investigating an issue affecting the ability to login to DonorPerfect. We apologize for any inconvenience this might be causing you, and we'll keep you posted with updates here.
Posted Mar 06, 2018 - 16:35 EST