Intermittent Payment Processing Errors
Incident Report for DonorPerfect
Resolved
This issue has been resolved. Thank you for your patience as teams worked to resolve the issue.
Posted Aug 04, 2021 - 11:04 EDT
Monitoring
There have been no additional errors or issues reported since 10:33 ET. Our payment processing partner's engineering team is continuing to monitor.
Posted Aug 04, 2021 - 10:41 EDT
Investigating
Our payment processing partner is monitoring intermittent connectivity issues that may impact credit card transactions. We will keep you updated here. Thank you.
Posted Aug 04, 2021 - 09:26 EDT
This incident affected: SafeSave Payments Gateway.