DonorPerfect Easy Reports Issue
Incident Report for DonorPerfect
Resolved
The Easy Reports issue has been resolved. Thank you for your patience as we resolved the issue.
Posted 14 days ago. Dec 04, 2018 - 12:37 EST
Investigating
We are currently investigating an issue with Easy Reports not loading properly. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. We will keep you updated here on the StatusPage.
Posted 14 days ago. Dec 04, 2018 - 12:26 EST
This incident affected: DonorPerfect.