DonorPerfect Access Issue
Incident Report for DonorPerfect
Resolved
We have resolved the DonorPerfect access issue. We apologize for any inconvenience this caused you, and we appreciate your patience as we quickly resolved the issue.
Posted Nov 11, 2019 - 11:47 EST
Identified
We've identified an issue that has caused problems accessing DonorPerfect. We're working hard to resolve the issue as quickly as possible, and we anticipate that will be in the next few minutes. Thank you for your patience.
Posted Nov 11, 2019 - 11:41 EST
This incident affected: DonorPerfect.