Phone Support Unavailable
Incident Report for DonorPerfect
Resolved
The phone system has been restored. Thank you for your patience while our team resolved this issue.
Posted Nov 09, 2017 - 15:43 EST
Investigating
We're currently investigating an issue that has caused a phone system outage. We apologize for this inconvenience, and our team is working hard to resolve the issue. Please contact our support team through chat or email for any technical support questions. We'll keep you updated on our progress here.
Posted Nov 09, 2017 - 15:16 EST