Phone Support Unavailable
Incident Report for DonorPerfect
Resolved
We have heard from our provider that this issue is resolved and we have confirmed that our phones are once again fully operational. Thank you for your patience as we worked through this - we greatly appreciate you!
Posted Sep 28, 2022 - 19:10 EDT
Monitoring
Our telephony service provider has implemented a fix and we are now seeing calls successfully connecting to our support representatives. We will continue to monitor to ensure the errors have been resolved. Thank you
Posted Sep 28, 2022 - 17:20 EDT
Identified
Thank you for your patience. Our telephony service provider has identified the problem and is working hard to restore our phone service as quickly as possible. The best way to reach our support team at this time is through Chat Support in the Help Menu of DonorPerfect (look for the question mark in the upper right corner).
Posted Sep 28, 2022 - 17:07 EDT
Investigating
We are currently investigating an issue that is causing connectivity and quality issues with our phone support. We are working hard to identify and resolve the issue, and we will keep you updated on the progress. The best way to reach our support team at this time is through Chat Support in the Help Menu of DonorPerfect (look for the question mark in the upper right corner).
Posted Sep 28, 2022 - 12:54 EDT
This incident affected: DonorPerfect.