Intermittent DonorPerfect Error
Incident Report for DonorPerfect
Postmortem

Thank you for your patience while we researched the root cause of this issue and we apologize for any impact this might have caused you. Our research found that one of our clients was using our integration API in a way that was causing a significantly excessive impact on our back-end servers, which slowed response times to some other clients intermittently. When we recognized this, we immediately disabled this client’s process and full service was restored. Our support staff reached out to the client to review the process and will work with them to make it more efficient. We will continue to look for improvements we can make to the API to better detect and monitor this condition in the future.

Posted Feb 26, 2020 - 17:29 EST

Resolved
We implemented a fix and we believe the issue has been resolved. We'll continue to monitor the system to ensure full resolution. Thank you for your patience.
Posted Feb 24, 2020 - 12:56 EST
Investigating
We are currently investigating an issue that is causing an error when logging into DonorPerfect. We apologize for this inconvenience and we are working hard to resolve this issue as quickly as possible.
Posted Feb 24, 2020 - 12:19 EST
This incident affected: DonorPerfect.