US Office Power Outage
Incident Report for DonorPerfect
Resolved
The power has been restored in our US office, as well as our phone lines. Phone support will be available today. Thank you for your patience and understanding as we worked around the power outage.
Posted Nov 04, 2019 - 08:53 EST
Update
We are still experiencing a power outage in our building, so the phone system has still not been fully restored. However, we do believe the power and phones will be restored over the weekend.

Thank you for your patience, and thank you to many of you who have been checking in with the team to ensure everyone is safe. We appreciate your kindness!
Posted Nov 01, 2019 - 15:43 EDT
Update
We have been able to partially restore phone service. You are now able to leave a voicemail and one of our team members will return your call as soon as they can. Our toll free number is not in service right now, so please dial 215-628-4343. You can still quickly access our support team through the chat support. Thank you for your patience.
Posted Nov 01, 2019 - 10:31 EDT
Update
Our support phone lines are currently down due to the power outage impacting our area. Chat and email are the only ways to contact our support team at this time. We apologize for this inconvenience, and we will post any updates here.
Posted Nov 01, 2019 - 09:22 EDT
Identified
Our US office is currently without power and as a result, our phone support times will be impacted. Chat and email are the best way to reach our Support Team. Thanks for your patience and we'll keep you posted here.
Posted Nov 01, 2019 - 07:57 EDT
This incident affected: DonorPerfect Community.