Some clients are unable to log into DonorPerfect
Incident Report for DonorPerfect
Postmortem

After the DonorPerfect login issues happened yesterday, we worked to resolve the issue quickly. Then, met with our team to better understand the issue, how we fixed it, and here's an explanation of what happened.

Sequence of Events

  • Yesterday at approximately 10:00am ET, we were alerted that some clients were receiving this error when running their new Dashboard reports: Content was blocked because it was not signed by a valid security certificate.
  • We discovered that this issue was only for those customers who were logging into DonorPerfect through Internet Explorer. Other browsers such as Chrome and Firefox were not experiencing the same issue.
  • Our staff quickly found the root cause and worked to resolve the Dashboard error for our Internet Explorer clients. In order to do this, we needed to update the security certificate (the thing that makes a secure website URL a valid https instead of http).
  • During the few moments we were updating the security certificate, this caused a temporary outage to the log in feature of DonorPerfect.
  • Once the certificate was updated, all affected features in DonorPerfect were restored back to full functionality.
  • Once all systems were operating normally, we monitored the situation to ensure it was fully resolved.

Note: No data was lost or compromised during this outage and your data remained secure.

We sincerely apologize for the issue some of you experienced yesterday and appreciate your patience as we resolved it.

Posted Aug 11, 2015 - 12:57 EDT

Resolved
The log in issue to DonorPerfect is resolved and we're monitoring the situation to ensure it continues to operate normally.
Posted Aug 10, 2015 - 12:06 EDT
Investigating
We're investigating an issue that some clients are unable to log into DonorPerfect. This is our highest priority to resolve as soon as possible.
Posted Aug 10, 2015 - 11:51 EDT