Intermittent Phone Connectivity Issues
Incident Report for DonorPerfect
Resolved
Our phone service provider has confirmed that the issue with phone call quality has been resolved. Thank you for your patience.
Posted Jan 22, 2020 - 11:19 EST
Monitoring
Our phone service provider has communicated that they have identified the issue that was affecting our phone system as well as many other phone systems across the country. Call quality has improved over the past hour, and our support team is successfully assisting customers over the phone. Thank you for your patience, and we'll continue to keep you updated on the status of this issue.
Posted Jan 21, 2020 - 13:04 EST
Investigating
We are currently investigating an issue that is affecting the quality of our phone system connectivity. We have been receiving reports that phone conversations with our support team are suffering from very poor sound quality. We recommend reaching out to our support team through Chat support until the phone system issues are resolved. Thank you for your patience.
Posted Jan 21, 2020 - 11:50 EST
This incident affected: DonorPerfect.