Intermittent Issues Processing E-Check Transactions
Incident Report for DonorPerfect
Resolved
Our payment processing vendor has confirmed that the electronic check processing issues have been resolved. Beginning at 2:44 PM ET, intermittent issues processing electronic check transactions occurred. By 4:05 PM ET, all remaining issues had been resolved.
Posted Jul 20, 2017 - 16:36 EDT
Investigating
Our payment processing vendor has reported intermittent issues processing electronic check transactions. This does not affect credit card transactions. We'll keep you posted with any updates we receive here on the StatusPage.
Posted Jul 20, 2017 - 16:02 EDT