Intermittent Slowness in DonorPerfect (Search, Parameters, and Backup/Restore)
Incident Report for DonorPerfect
Resolved
Our team has implemented several fixes to improve performance in Search, Parameters, and Backup/Restore this week. After monitoring the performance of DonorPerfect since implementing these fixes, we have not observed any further performance issues, nor have any additional issues been reported. We believe the previously reported issues related to Search, Parameters, and Backup/Restore have been resolved. Thank you for your patience and understanding as our team continues to improve your DonorPerfect experience.
Posted Feb 16, 2018 - 15:34 EST
Update
Our team has deployed an update that should improve the performance of Search. We're continuing to investigate and monitor our servers for any slowness issues and will keep you updated here. Thank you for your patience.
Posted Feb 07, 2018 - 17:15 EST
Investigating
Our team is currently investigating intermittent slowness issues in Search, Parameters, and Backup/Restore. Reports of slowness issues have been sporadic, and we are still investigating the root cause of the issue. Our development team anticipates that it may take a few days to completely understand and eradicate the intermittent slowness.

We’re currently focusing on Search, and we’ll continue to post updates as we learn more. In the meantime, if you encounter any kind of slowness in Search, Parameters, or Backup/Restore, logging out of DonorPerfect and logging back in may resolve the issue. We appreciate your patience as we resolve this issue, and we will keep you updated here.
Posted Feb 07, 2018 - 16:07 EST