Intermittent Insta-Charge Issue
Incident Report for DonorPerfect
Resolved
We have implemented a fix and the Insta-Charge issue has been resolved. Thank you for your patience as we resolved the issue.
Posted Dec 02, 2019 - 17:24 EST
Investigating
We are currently investigating an intermittent issue that is causing Insta-Charge to time out when processing a payment. We apologize for any inconvenience this is causing you, and we are working hard to resolve the issue as quickly as possible.
Posted Dec 02, 2019 - 15:48 EST
This incident affected: DonorPerfect.