Chat Support Unavailable in the DonorPerfect Help Menu
Incident Report for DonorPerfect
Resolved
Chat service has continued without incident since 1:00 PM ET. This issue has been resolved.
Posted May 22, 2017 - 14:30 EDT
Monitoring
Our chat service through the DonorPerfect Help Menu is back online and available. We are going to monitor performance over the next hour. Thank you.
Posted May 22, 2017 - 13:05 EDT
Investigating
We're experiencing an issue accessing our chat support in the DonorPerfect Help Menu and are currently working to correct the issue. However, you can access chat support through Community to speak with one of our chat representatives. We apologize for the interruption. We'll keep you updated on the status here.
Posted May 22, 2017 - 12:55 EDT