DonorPerfect currently unavailable
Incident Report for DonorPerfect
Resolved
All issues have been resolved and all services have returned to normal. We apologize for any inconvenience.
Posted Oct 16, 2017 - 00:09 EDT
Update
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2017 - 21:50 EDT
Monitoring
DPO is available again for many clients, and should be available to the remainder of our clients soon. We apologize for the inconvenience.
Posted Oct 15, 2017 - 21:50 EDT
Investigating
DonorPerfect is currently unavailable - we're investigating and hope to resolve the issue shortly.
Posted Oct 15, 2017 - 21:08 EDT