Slowness during DonorPerfect Login
Incident Report for DonorPerfect
Postmortem

We have confirmed that the slowness during DonorPerfect login has been resolved. Thank you for your patience as we resolved this issue.

We are aware of intermittent login issues that also occurred yesterday afternoon. Yesterday, we received reports of some clients receiving intermittent errors or timeouts during API retrievals or when logging into DonorPerfect. We identified that a server related to the service was experiencing some instability which we addressed with a reboot and additional maintenance. We've continued to monitor both yesterday and today and believe we have addressed the issue.

We appreciate your patience and continue to strive to improve your DonorPerfect experience.

Posted 4 months ago. Apr 01, 2019 - 16:10 EDT

Resolved
This incident has been resolved.
Posted 4 months ago. Apr 01, 2019 - 16:08 EDT
Monitoring
We have implemented a fix and we are no longer seeing the delay during login. We'll continue to monitor DonorPerfect's performance and keep you updated on the status.
Posted 4 months ago. Apr 01, 2019 - 10:24 EDT
Investigating
We are currently investigating an issue that is causing slowness when logging into DonorPerfect. We have received reports of a delay after entering the User ID and password and clicking the Login button. We apologize for this inconvenience and are working hard to resolve this issue.
Posted 4 months ago. Apr 01, 2019 - 10:08 EDT
This incident affected: DonorPerfect.