Intermittent Phone Issues
Incident Report for DonorPerfect
Resolved
This issue has been resolved. The underlying cause was identified as a communication failure between the Philadelphia and New York City central offices of our phone carrier. Thank you for your patience.
Posted 14 days ago. Oct 03, 2019 - 08:33 EDT
Investigating
We are currently aware of an outage that is affecting our phone system. Our local phone numbers beginning with area codes 215, 267, and 301 have been unreachable. We know that the source of this issue is with our phone carrier. We are investigating the issue and will keep you posted with updates here on the StatusPage.
Posted 14 days ago. Oct 02, 2019 - 16:25 EDT
This incident affected: DonorPerfect.