Email Service Delays
Incident Report for DonorPerfect
Resolved
End-to-end email delivery times are back to normal ranges. This issue has been resolved. We know that email delivery is critical to your business and sincerely apologize for any inconvenience this caused.
Posted Sep 12, 2022 - 20:08 EDT
Monitoring
Our team has implemented a fix and emails are now being sent. We will continue to monitor this issue until we are all clear. Thank you for your patience. We will keep you updated here!
Posted Sep 12, 2022 - 17:58 EDT
Update
We have identified the issue and are working to resolve it. There may be times when users are logged out over the next 3 hours as we implement a fix. Anyone who is logged out should be able to log back into DP immediately.
Posted Sep 12, 2022 - 16:06 EDT
Identified
Our email service for DonorPerfect and Online Forms is experiencing some delays. We apologize for the inconvenience. We'll update you here when the email flow has been stabilized.
Posted Sep 12, 2022 - 14:54 EDT
This incident affected: DonorPerfect, DonorPerfect Online Forms, ReadySetAuction, and New DP Forms (Beta).