Monthly Giving Failed Transaction Issue
Incident Report for DonorPerfect
Resolved
The Monthly Giving issue has been resolved. We have successfully voided the duplicate charges prior to settlement so that your donors are not affected by the Monthly Giving issue. We have also fixed the original problem that caused the issue so that it does not occur again.

Thank you for your patience as we resolved this issue. We apologize for any inconvenience you have experienced, and we will continue to strive to improve your experience with DonorPerfect
Posted 22 days ago. Jun 25, 2019 - 17:02 EDT
Investigating
We are currently investigating an issue that may have caused some Monthly Giving transactions to appear as if they failed in your system. We have been able to confirm that Monthly Giving did successfully process transactions, so the Failed status is incorrect. We also have recognized that some transactions were duplicated as a result of this issue.

We are currently working on resolving the issue by voiding duplicate charges prior to settlement so that the issue does not impact your donors in any way. We are also working on correcting the Failed status for the transactions in DonorPerfect. We apologize for this inconvenience, and we will continue to update you on our progress.
Posted 22 days ago. Jun 25, 2019 - 11:22 EDT
This incident affected: DonorPerfect.