Intermittent Phone Service Issue
Incident Report for DonorPerfect
Resolved
Our service provider has confirmed that they resolved the phone issues over the weekend. Thank you for your patience.
Posted 3 months ago. Jul 01, 2019 - 09:21 EDT
Update
Our service provider has continued to work on the phone issues, however, they have not confirmed that the issues have been fully resolved. They will continue to work over the weekend so that we can provide the excellent phone service you are accustomed to. Thank you for your patience, and we'll update you on their progress on Monday.
Posted 3 months ago. Jun 28, 2019 - 16:31 EDT
Identified
We are aware of an issue that is intermittently affecting the quality of phone calls to our team. Our phone service provider is working on a resolution to the problem. There is a small possibility that we may lose phone service for a short period of time. Thank you for your patience as our service provider resolves this issue, and we'll keep you updated on their progress here on the StatusPage.
Posted 3 months ago. Jun 28, 2019 - 09:08 EDT
This incident affected: DonorPerfect.