DonorPerfect Login Issues
Incident Report for DonorPerfect
Postmortem

We apologize for the login issues you may have experienced last week. In researching the issue, we traced the cause to excessive usage of our API by several of our customer/partners, which impacted the ability of our login services to service all authentication requests. We temporarily suspended the API access for the accounts and normal login service was restored throughout the system, though the issue recurred several times before we could resolve it completely.

Fortunately, we are already in the process of researching and testing rate-limit/throttling technology intended to prevent this type of impact in the future. And we plan on taking several other steps to better isolate the impact of API traffic from the online DPO services. We hope to implement both changes as soon as they can be fully tested.

Again, we apologize for any inconvenience this caused you and greatly appreciate the trust you have placed in DonorPerfect.

Posted Aug 17, 2020 - 13:20 EDT

Resolved
This issue has been resolved. We apologize for the inconvenience this has caused throughout the day. Thank you for your patience.
Posted Aug 14, 2020 - 14:43 EDT
Investigating
We are investigating an issue that is preventing some users from logging into DonorPerfect. We apologize for this inconvenience and are working hard to resolve this as quickly as possible.
Posted Aug 14, 2020 - 14:14 EDT
This incident affected: DonorPerfect.