Intermittent Payment Processing Errors Reported
Incident Report for DonorPerfect
Resolved
There have no further errors since the fix was implemented. Thank you for your patience while our payment processing partner worked to resolve this issue.
Posted Nov 26, 2021 - 12:15 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2021 - 11:14 EST
Investigating
Our payment processing partner is currently investigating platform connectivity issues. We will keep you updated here.
Posted Nov 26, 2021 - 10:44 EST
This incident affected: SafeSave Payments Gateway.