DonorPerfect Intermittent Errors & Login Issues
Incident Report for DonorPerfect
Resolved
We haven't seen any additional errors. This incident has been resolved. Thank you for your patience.
Posted Jul 25, 2022 - 18:23 EDT
Monitoring
We are continuing to monitor reports of intermittent errors that say "system is unavailable". If you experience this error, please retry your previous action. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Jul 25, 2022 - 14:29 EDT
This incident affected: DonorPerfect and DonorPerfect Online Forms.