Phones and Internet Down for DonorPerfect Canada
Incident Report for DonorPerfect
Resolved
Phones and internet are back up and running. Thank you for your patience!
Posted Sep 10, 2015 - 15:36 EDT
Monitoring
Phones and internet appear to be back up. However, we will continue to monitor the situation closely.
Posted Sep 09, 2015 - 16:32 EDT
Investigating
The DonorPerfect Canada team is, once again, experiencing technical difficulties with their phones and internet. Please call [(215) 628-4343], email (support@donorperfect.com), or chat (accessible through the Help Menu in DonorPerfect) our U.S. support team if you need any assistance. We're working with the vendor to correct the issue. We'll update you when the situation has been resolved.
Posted Sep 09, 2015 - 14:27 EDT