Batch Settlement Issues for Payment Processing
Incident Report for DonorPerfect
Resolved
This issue has now been resolved. All affected settlements have been successfully settled. Transactions that received erroneous response data were withheld from the settlement.
Posted Oct 11, 2016 - 23:01 EDT
Monitoring
Our vendor has narrowed the incident duration to between approximately 7:00 am ET thru 9:40 am ET on Monday October 10. This incident resulted in some transactions returning incorrect response data. This incorrect response data is what is preventing the failing settlements from succeeding. We, with our vendor, are working to isolate the transactions with erroneous response data so that we can settle the unaffected transactions. We will keep you updated here.
Posted Oct 11, 2016 - 16:32 EDT
Identified
Our processing merchant has identified a small subset of isolated settlement issues related to open batches. You will know that you're affected if you receive an alert indicating that one of your settlements has failed. If affected, you may contact SafeSave (800-220-8611). We'll continue working with our vendor to resolve these issues and will keep you updated here.
Posted Oct 11, 2016 - 11:28 EDT