Intermittent Insta-Charge Issue
Incident Report for DonorPerfect
Resolved
The Insta-Charge issue has been resolved. We apologize for any inconvenience this issue caused you, and we appreciate your patience as we resolved the problem.
Posted about 2 months ago. Aug 19, 2019 - 13:00 EDT
Investigating
We're currently investigating an issue that is causing an error when processing an Insta-Charge payment. We apologize for any inconvenience this might be causing you, and we are working hard to resolve the problem as quickly as possible. Thank you for your patience.
Posted about 2 months ago. Aug 19, 2019 - 09:21 EDT
This incident affected: DonorPerfect.