Intermittent Login Issue
Incident Report for DonorPerfect
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 02, 2019 - 08:48 EDT
Investigating
We're currently investigating an issue that is causing intermittent slowness when attempting to log in. We apologize for the inconvenience, and we'll keep you updated here on the StatusPage.
Posted 3 months ago. Aug 01, 2019 - 12:42 EDT
This incident affected: DonorPerfect.