Intermittent Phone Issues for Support Line
Incident Report for DonorPerfect
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 30, 2019 - 15:35 EDT
Monitoring
We've been working with our phone carrier who is now onsite and have made some adjustments to routing significantly decreasing the chance customers would receive a busy signal when calling into support.
Posted 2 months ago. Aug 13, 2019 - 17:18 EDT
Investigating
We are currently investigating an issue with our phone carrier where clients calling the support line receive a busy signal. To reach our support team, please use Chat which is located under the Help (?) menu in the upper right corner. Thanks for your patience while we work with our phone provider to address this issue.
Posted 2 months ago. Aug 13, 2019 - 11:59 EDT
This incident affected: DonorPerfect Community.