Slowness Running Easy Reports

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 16:44 EST

Investigating

We’re currently investigating an issue impacting Easy Reports that may cause reports to run slowly or, in some cases, fail to complete. We apologize for the disruption and are working to resolve it as quickly as possible. Updates will be shared here as we learn more.
Posted Jan 28, 2026 - 15:22 EST
This incident affected: DonorPerfect.