This incident has been resolved. Please note that the next time you log in, you will be prompted to enter your MFA code, even if you previously selected the option to remember your device for 10 days.
We apologize for the inconvenience and appreciate your patience. Thank you!
Posted Aug 18, 2026 - 11:16 EDT
Update
We are continuing to investigate reports of slowness throughout DonorPerfect, as well as extended loading times and spinning when attempting to log in. We apologize for the inconvenience and appreciate your patience as our team works to identify the root cause and resolve the issue as quickly as possible.
Posted Aug 18, 2026 - 11:10 EDT
Investigating
We are currently investigating an error appearing when attempting to log in to DonorPerfect. We are working hard to determine the root cause of this issue and resolve it as fast as possible. We will keep you updated here. Thank you for your patience.