Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2026 - 20:00 EDT
Scheduled
We will be performing maintenance on DonorPerfect, Drag-N-Drop Forms, and Classic Forms on Thursday, June 25th, beginning at 8:00 PM ET. The maintenance window is expected to last approximately one hour.
During this time, there will be an estimated 30-minute period of downtime when DonorPerfect, Drag-N-Drop Forms and Classic Forms will be temporarily unavailable. While services are offline, Online Forms will not be able to process payments.
Givecloud will continue processing donations without interruption. However, during the maintenance window, downloads from Drag & Drop Forms and emails sent through DonorPerfect email templates may experience delays.
Thank you for your patience and understanding as we continue working to improve DonorPerfect.
Posted Jun 25, 2026 - 10:20 EDT
This scheduled maintenance affected: DonorPerfect, DonorPerfect Classic Online Forms, and DonorPerfect Drag & Drop Online Forms.