Slowness Navigating within DonorPerfect

Incident Report for DonorPerfect

Resolved

After monitoring the fix, we have not observed any further issues with slowness in DonorPerfect. We are confident that the issue has been resolved. Thank you for your patience while we worked hard to correct this issue.
Posted Aug 18, 2026 - 15:03 EDT

Monitoring

Our Development Team has implemented a fix to address the issue that was causing slowness in DonorPerfect. We are continuing to monitor response times and overall performance and will provide updates here as needed. Thank you for your patience.
Posted Aug 18, 2026 - 12:59 EDT

Investigating

We are investigating an issue causing slowness in DonorPerfect. We apologize for this inconvenience and we are working hard to resolve the issue as quickly as possible.
Posted Aug 18, 2026 - 11:35 EDT
This incident affected: DonorPerfect.