Performance Slowness

Incident Report for DonorPerfect

Resolved

After monitoring the applied fix over the last several days we haven't experienced any additional timeout errors. We are confident that our fix was successful. Thank you for your patience and understanding.
Posted Mar 17, 2025 - 13:17 EDT

Monitoring

Our team has deployed a fix that is helping to ease the slowness while they continue to investigate ways to further reduce recurrence. At this time we have seen our systems return to normal response times and are monitoring all systems to ensure they stay responsive.
Posted Mar 13, 2025 - 14:02 EDT

Identified

Our team has identified the issue that is causing these timeout errors. We are working on implementing a fix to help alleviate this soon. Thank you for your patience, and we will keep you updated here!
Posted Mar 12, 2025 - 13:41 EDT

Investigating

We are currently investigating various timeout errors when completing tasks in DonorPerfect. We are working hard to identify and fix the issue. Thank you for your patience and understanding. We will keep you updated here!
Posted Mar 11, 2025 - 15:17 EDT
This incident affected: DonorPerfect.