Intermittent Payment Processing Issues

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted May 06, 2026 - 20:12 EDT

Monitoring

Our payment processing vendor has implemented a fix and is actively monitoring the system to ensure payment processing remains stable and fully operational.
Posted May 06, 2026 - 18:46 EDT

Identified

Our payment processing vendor is currently experiencing intermittent issues with electronic payment processing. They have identified the root cause and are actively working to implement a fix and restore normal service as quickly as possible. We will continue to provide updates here as they become available.
Posted May 06, 2026 - 18:18 EDT
This incident affected: DonorPerfect, DonorPerfect Classic Online Forms, New DonorPerfect Online Forms, and SafeSave Payments Gateway.