Chat support unavailable from within DonorPerfect

Incident Report for DonorPerfect

Resolved

In product Chat Support is now functioning as intended. Thank you for your patience!
Posted May 19, 2025 - 15:01 EDT

Investigating

We are currently experiencing an issue with our in product Chat Support solution for DonorPerfect, we are working hard to resolve the issue. In the mean time you can still access Chat Support through our Community site. Go to (?)Help > Knowledgebase > Click on your user name in the top right corner and select Chat Support > then Chat Now. We appreciate your patience as we work to restore this service.
Posted May 19, 2025 - 14:16 EDT
This incident affected: DonorPerfect.