Email Deliverability Outage - DonorPerfect, RSA, Online Forms
Incident Report for DonorPerfect
Resolved
This issue is fully resolved. We understand the inconvenience that this has caused and are truly grateful for your patience as we worked through this with our partner. We took extra time to ensure that all emails that were queued would be processed and our expectation is that every email, while delayed, has been delivered. If you have any questions then please talk with our support team who are standing by and are ready to help. Once again - thank you!
Posted Jul 24, 2024 - 08:25 EDT
Monitoring
The issue has been resolved and the queued emails are being sent. We are monitoring the situation to ensure everything is fully resolved. Thank you for your patience with us while we addressed this issue.
Posted Jul 23, 2024 - 23:15 EDT
Update
We understand the inconvenience this is causing and we truly are grateful for your patience as we continue to work with our email vendor to resolve this issue. Please note that all non-email processes continue to function as normal. For example, Automatic Monthly Giving will continue to process even though the confirmation email is not being sent immediately. If you have any questions then please contact the DP Support Team and we will continue to post updates here. Thank you for your continued patience.
Posted Jul 23, 2024 - 17:10 EDT
Update
We are continuing to work with our email vendor to resolve this outage. For users who have setup security questions previously and have forgotten their passwords, please contact DP Support and we can assist you in getting back into DonorPerfect. We will continue to update you here with any new information. We apologize for any inconvenience this is causing.
Posted Jul 23, 2024 - 10:05 EDT
Update
We understand the impact this is having on your organization and apologize. We continue working with our third party vendor to fix this email outage. The emails are still queued for processing and when this is resolved we believe they will be sent. As soon we have more information we will update you here. Thank you for your patience.
Posted Jul 22, 2024 - 17:20 EDT
Update
We are continuing to work with our third party vendor to resolve this issue as a high priority. We will keep you informed with any updates here. We apologize for any inconvenience.
Posted Jul 22, 2024 - 14:14 EDT
Identified
We have identified the issue and are working with our third party vendor to resolve the email outage. We apologize for the impact to your organization. We will keep you updated here.
Posted Jul 22, 2024 - 10:15 EDT
Investigating
We are currently investigating an issue where emails are not sending from DonorPerfect, ReadySetAuction, and Online Forms (Classic and New), this includes receipts and password resets. Emails are currently being queued to send, however are not being delivered at this time. This is a high priority issue and we are actively researching and trying to resolve this. As soon as we have more information we will post here.
Posted Jul 22, 2024 - 09:26 EDT
This incident affected: DonorPerfect, DonorPerfect Classic Online Forms, New DonorPerfect Online Forms, DPMobile App & XML API, and ReadySetAuction.