Intermittent Phone Issues
Incident Report for DonorPerfect
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 08:25 EDT
Monitoring
Our carrier has indicated that the intermittent phone issues should now be resolved. We'll continue to monitor this issue for a few hours to ensure it has been fully resolved. Thank you for your patience.
Posted Oct 18, 2019 - 14:44 EDT
Update
Our team has confirmed that the phone issue has been caused by a problem with our service carrier. The issue has affected a large subset of our carrier's customers. We apologize for the inconvenience, and we will keep you posted on the updates we receive.
Posted Oct 16, 2019 - 15:10 EDT
Investigating
We are currently investigating an issue that is affecting our phone system. Some of our support representatives have reported issues answering calls and not being able to hear the voice on the other end. We are investigating the issue and will keep you posted with updates here on the StatusPage. You can still access our support team through Chat in the Help menu in the upper-right corner in DonorPerfect. Thank you for your patience.
Posted Oct 16, 2019 - 11:38 EDT
This incident affected: DonorPerfect.