DonorPerfect Dashboards and Easy Reports Issue

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 16:46 EDT

Monitoring

After restarting the reporting services, report run times have returned to normal. We will continue monitoring to ensure everything continues to run as expected.
Posted Jun 30, 2026 - 15:52 EDT

Investigating

We're currently investigating an issue affecting Dashboards and Easy Reports not loading properly. We apologize for this inconvenience, and we'll keep you updated on our progress here.
Posted Jun 30, 2026 - 15:25 EDT
This incident affected: DonorPerfect.