Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2026 - 20:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 02, 2026 - 10:21 EDT
Scheduled
We will be performing scheduled maintenance on DonorPerfect and DonorPerfect Drag & Drop Online Forms on Thursday, April 2, starting at 8:00 PM ET. The update is expected to take about one hour.
During this time, there will be a brief downtime period (approximately 10 minutes) while updates are applied. During this window, DonorPerfect may be temporarily unavailable, and Drag & Drop Online Forms may not process donations.
Classic Online Forms will continue to function normally and process donations without interruption. However, downloads from Drag & Drop forms and emails sent through DonorPerfect email templates may be delayed during the maintenance period.
Thank you for your patience as we work to improve DonorPerfect.
Posted Apr 02, 2026 - 08:22 EDT
This scheduled maintenance affected: DonorPerfect and New DonorPerfect Online Forms.